Comments on "Using WYSIWYG htmlArea HTML editor with Movable Type":
[ 1 : Permalink ]

I installed your version of htmlArea but the htmlArea editor still does not show up in the textarea box. Nothing changed on the standard Movable Type editing page. I installed all of your pieces based on the root of my installation (the "cgi-bin" folder). In other words, mt.cgi and htmlarea.js share the same folder. How do I turn on WYSIWYG mode?

Thanks!

Posted by at October 2, 2003 09:56 AM
[ 2 : Permalink ]

Hi, there is a problem that with default Apache installation all files in "cgi-bin" folder will be treated as cgi script. This will make images we need to display as button can't display (your Apache will try to exercise those images!).

You'd re-configure your apache's httpd.conf configuration file, or just install whole MT into other folder like MT/

Good luck.

I'll try to make some more generic solution in next release.

Posted by Jedi at October 2, 2003 04:49 PM
[ 3 : Permalink ]

Since my ISP controls the Apache configuration of my web space, I don't have any control over the httpd.conf file.

Is there another place to put htmlArea? Can I put it at the same level as the cgi-bin folder? If so, what paths should I change in which files?

Thanks!

Posted by at October 3, 2003 08:08 AM
[ 4 : Permalink ]

What you should/could try is put images/ into static webpage directory (e.g. www/) and then modify all htmlArea's Javascript files (*.js), and please also modify your mt/tmpl/cms/edit_entry.tmpl. You may find this in edit_entry.tmpl:

<img style="border-top: 1px solid #e9e9e9; border-left: 1px solid #e9e9e9; border-right: 1px solid black; border-bottom: 1px solid black; margin: 0;visibility: auto" id="wysiwyg" onclick="document.getElementById('wysiwyg').style.visibility = 'hidden';HTMLArea.replace('text_more');HTMLArea.replace('text');" src="images/ed_color_fg.gif" alt="" title="HTMLEdit">

Please modify the src attribution to represent what you have done.

Posted by Jedi at October 3, 2003 12:11 PM
[ 5 : Permalink ]

Hello Jedi!

I have installed your package as instructed. However the new entry page loads with errors.

"Can't move focus to control because it is invisible, not enabled or of a type that does not accept focus."

Buttons are displaying with no errors however they do not do anything... the buttons appear to be located in mt/cgi-bin/images/ (there are also a copy under mt/images/ )

Any help will be appreciated.

Thanks

Posted by Philip at December 16, 2003 12:50 PM
[ 6 : Permalink ]

Erm, I installed it and it did nothing. Then I looked againat the contents of the .tgz and I see there is no new edit template. What has to be done to the edit template? Do we have to figure it out for ourselves based on the HTMLarea examples?

Posted by steve koppelman at May 1, 2004 12:24 PM
[ 7 : Permalink ]

I've got htmlArea working w/MT3; details at my site: http://www.allthepages.org/archives/001068.html

Posted by mike rodriquez at August 4, 2004 09:31 AM
[ 8 : Permalink ]

Hello thanks for all

bur i have problem i have done al this and get my text inside the spellcheck window , but i dont get any sugestion for words, and i use w32 version of aspell, i have read that i have to take home som lib to install , have you get it to work in windows only with the w32 version if so i would be grateful if you told me what you did

Thanks Tomas

Posted by tomas at January 14, 2005 06:46 AM
Leave Your Comments
Personal Informaion








Remember personal info?



Enter the Security Code shown above:
Comment Area