March 09, 2003

[活字印刷] 新的 Movable Type 安裝檔Alt-E

最新的 Movable Type 2.63 的 Windows 安裝檔包好了。應該修掉了大量的問題了。請從 http://p4.elixus.org/dist/mt-2.63.exe 下載。

多謝 autrijus 熱力相助(大心)

由 Jedi 於 March 9, 2003 08:09 PM 所發表 | 引用 (2)
迴響Alt-C
[ 1 : 靜態鏈結 ]

抓到一個bug? (不是 win32 版)

從 p4.elixus.org 的 snap 抓下來的

mt.tar.gz 中

index.html 有一個連結到安裝指引的

http://xxxxxxxx/mt/docs/zh_tw/mtinstall.html


但是在docs 裡面只有 zh-tw 裡面有手冊
zh_tw 裡面則是空的



不過我知道你 docs-2.63還沒有翻譯.. :)

macpaul 於 March 9, 2003 10:19 PM 所發表
[ 2 : 靜態鏈結 ]

有個小問題..

上傳資料時,若選擇指定目錄 會有下列的錯誤訊息

mkdir C:\Program Files\OurInternet\Movable Type\mt\archives\C:\: Invalid argument at C:/Program Files/OurInternet/Movable Type/mt/lib/MT/FileMgr/Local.pm line 106

yyans 於 March 10, 2003 03:08 PM 所發表
[ 3 : 靜態鏈結 ]

macpaul: zh_tw should be REMOVED
all documents have been updated to 2.63 already.

yyans: We'll fix that as soon as possible.

Jedi 於 March 10, 2003 05:22 PM 所發表
[ 4 : 靜態鏈結 ]

不好意思,臨時抱佛腳 遇到嚴重問題
我現在正要幫日日春協會蓋blog,
但主機的OS是 window2000 server版.
以致於我下載並安裝mt2.63.exe後,
瀏覽器沒有出現上次在紫藤廬教學所出現的管理介面

用檔案總管開啟C:\Program Files\OurInternet\Movable Type\mt\mt.cgi或index.html也只見到一堆html碼

不知道這種情形該如何解決呢?

shaman 於 March 11, 2003 05:42 PM 所發表
[ 5 : 靜態鏈結 ]

how about this:
http://localhost/mt.cgi

btw, 如果是已經安裝過 IIS 的 Win2k Server, 可能要注意一下 port 的問題...

Jedi 於 March 11, 2003 06:06 PM 所發表
[ 6 : 靜態鏈結 ]

這個也試過了,無法顯示網頁
只能回到上一頁http://localhost

該電腦確實是已安裝過 IIS 的 Win2k Server...

shaman 於 March 11, 2003 11:31 PM 所發表
[ 7 : 靜態鏈結 ]

shaman: 呃,那就是 IIS 的關係了。你恐怕得先把 IIS 停掉,纔能夠正常安裝 Movable Type. 或者是在 IIS 裡加以設定,而不要用 Apache. 或者是讓 Movable Type 用不同的連接埠...

關於這些細節,如果你有工程師/網管人員可以叫用的話,直接找他們會比較快...

Jedi 於 March 12, 2003 12:09 AM 所發表
[ 8 : 靜態鏈結 ]

不好意思,請問一下:在重建的時候,「正在重建」的視窗出現了好幾行的
MT::App::CMS=HASH(0x8065504) Use of uninitialized value in substitution iterator at /var/www/cgi-bin/mt/lib/MT/Util.pm line 106.

請問是什麼意思……?不知如何除錯,是 Util.pm 這個檔的問題,還是 CMS.pm 的問題?或者…我什麼東西沒有填?

mrcat 於 March 15, 2003 02:18 PM 所發表
[ 9 : 靜態鏈結 ]

據說是無傷大雅的錯誤訊息...@@"

呃,先當作沒看到吧.. XD

Jedi 於 March 15, 2003 07:10 PM 所發表
[ 10 : 靜態鏈結 ]

不好意思請問一下 為什麼連到oin-setup.cgi是一片空白
不過index.html是正常的@_@
我是用2.63的安裝檔 os是win2000 之前沒裝過iis
謝謝>

happy 於 April 20, 2003 09:22 PM 所發表
[ 11 : 靜態鏈結 ]

to happy:
按照妳所使用的系統,理論上妳不需要自己連去 oin-setup.cgi 啦。安裝程式會自動做完所有該做的事,所以妳直接連到 mt.cgi ,然後繼續調整各項組態吧。

Jedi 於 April 20, 2003 09:25 PM 所發表
[ 12 : 靜態鏈結 ]

我安裝完的時候網頁出現錯誤
所以我是自己連到mt.cgi設定的沒錯@_@
可是等我設定然後重建檔案 再來要檢視我的網站的時候
發現它會自動導到oin-setup.cgi
比如說我架在http://xxx.xxx.xxx.xxx/
他會自動導到http://xxx.xxx.xxx.xxx/oin-setup.cgi
然後就是一片空白
我有試著移除過mt跟apache 然後只灌apache
竟然也會自動轉址ㄟ 真是看到鬼XD
btw 謝謝jedi大^_^

happy 於 April 20, 2003 11:03 PM 所發表
[ 13 : 靜態鏈結 ]

to happy:
既然有出現過錯誤訊息,那麼請提供錯誤訊息?

Jedi 於 April 21, 2003 02:37 AM 所發表
[ 14 : 靜態鏈結 ]

就是安裝完後不是會連到localhost嗎
然後瀏覽器就http-500 內部伺服器錯誤
:D~
所以後來我是直接打http://MY.IP/mt.cgi去做設定的

happy 於 April 21, 2003 11:02 AM 所發表
[ 15 : 靜態鏈結 ]

聽起來是很神秘的 Windows 纔會出現的問題。大致的原因是,可能妳的 DHCP 伺服器扔給了妳的 Windows 某個網域名稱,所以 http://localhost/ 可能就變成了 http://localhost.foo.bar.paz/ 之類的東西,然後就爛掉了。

不然就是(不應該發生的) apache 沒設好。滋滋...

Jedi 於 April 21, 2003 11:28 AM 所發表
[ 16 : 靜態鏈結 ]

真的是不知道該怎麼說
我把mt-load.cgi砍了之後就一切正常了
@_@
為我的白爛浪費Jedi大的時間真是不好意思
小弟頓首再拜

happy 於 April 21, 2003 01:45 PM 所發表
[ 17 : 靜態鏈結 ]

不會浪費時間啦。祇是這個問題看起來錯綜複雜(?),有機會應該來研究一下纔是...

Jedi 於 April 21, 2003 01:55 PM 所發表
[ 18 : 靜態鏈結 ]

[1]
幫我的女人問一下,怎樣才能將她的文字,被blog.elixus.org/收錄呢?
由 overjoy 於 April 21, 2003 12:37 PM 所發表
[2]
這好像是 FAQ 了...
請到 http://meta.elixus.org 登錄即可.....
由 Jedi 於 April 21, 2003 01:28 PM 所發表
[3]
對不起,我知道要去登錄,但登錄了卻還沒出現呢?
另外我在貼文章時,系統會回傳錯誤訊息,不知該如何解?

嗯!擺回對的地方

overjoy 於 April 21, 2003 03:02 PM 所發表
[ 19 : 靜態鏈結 ]

我用這個安裝檔安裝在中文的windows XP上。
除了trackback的功能之外,一切都正常。
以下是MT的錯誤訊息,有人有同樣的狀況嗎?
Ping 'http://imago-wonderdog.homeip.net/mt-tb.cgi/5' failed: HTTP error: 500 Internal Server Error

imago 於 April 29, 2003 08:37 AM 所發表
[ 20 : 靜態鏈結 ]

請問可不可以考慮架設一個論壇來討論這些東西呢?

boogieman 於 April 29, 2003 05:45 PM 所發表
[ 21 : 靜態鏈結 ]

您好:
我想要下載 http://p4.elixus.org/dist/mt-2.64.exe
但是它顯示的訊息
Forbidden
You don't have permission to access /dist/mt-2.64.exe on this server.
--------------------------------------------------------------------------------

Apache/1.3.28 Server at p4.elixus.org Port 80
請問如何解決呢?謝謝!
max

max 於 August 13, 2003 04:54 PM 所發表
[ 22 : 靜態鏈結 ]

to max:
呃,因為放檔案的 autrijus 忘記改檔案權限了。請從 http://mtbook.net 抓這個安裝檔吧!

Jedi 於 August 13, 2003 05:34 PM 所發表
給我迴響吧!