February 14, 2003

[活字印刷] Movable Type 2.60 繁簡中文語系檔Alt-E

我已經做完 Movable Type 2.60 版的繁體中文語系檔簡體中文語系檔了。這兩個檔案都是 UTF-8 的。請取用。許多稍早在 2.51 版語系檔未修正的用語也在此修正完畢。應該是完成度九成以上的語系檔了。

那麼,有沒有人要贊助我更新手冊了?

由 Jedi 於 February 14, 2003 01:55 PM 所發表 | 引用 (1)
迴響Alt-C
[ 1 : 靜態鏈結 ]

為什麼我中文化輸入的文章都會是亂碼呢?
我想是UTF-8的關係..
可不可以說一下到底有那些檔案裡有iso-8895-1需要改成utf-8呢?
還有平常要用什麼編輯器來修改utf-8的文字呀, 用WORDPAD等都會成了亂碼了..

yoyolai 於 February 14, 2003 05:46 PM 所發表
[ 2 : 靜態鏈結 ]

呃,應該是在 extlib 裡面有個 CGI.pm
需要把所有的 iso-8859-1 改成 UTF-8

在 windows 底下可以用 UltraEdit 來處理 UTF-8 純文字檔案。

Jedi 於 February 14, 2003 05:55 PM 所發表
[ 3 : 靜態鏈結 ]

唉.. 還是一樣耶..
剛照著http://www.movabletype.org/l10n/traditional_chinese/index.shtml
這裡的說明改了mt.cfg裡的兩個地方加上您說的cgi.pm,現在可以打和儲存中文了, 可是首頁的文字還是都是亂碼,也不會換行..
http://yoyolai.d2g.com

謝謝您的幫忙了..

yoyolai 於 February 14, 2003 06:37 PM 所發表
[ 4 : 靜態鏈結 ]

啊..那..
有沒有可能,請JEDI將貴站現在可以用的這個MT資料夾包成ZIP檔...試試看能不能用..:P
實在是試了很久.有點灰心..:(

yoyolai 於 February 14, 2003 08:56 PM 所發表
[ 5 : 靜態鏈結 ]

看來是2.6在重建檔案時會出現問題?!
是BUG嗎?

yoyolai 於 February 14, 2003 09:16 PM 所發表
[ 6 : 靜態鏈結 ]

唔... 目前這一份是 2.51 版。
2.6 版裡的這個問題...呃...我們繼續觀察觀察...:Q

Jedi 於 February 14, 2003 09:35 PM 所發表
[ 7 : 靜態鏈結 ]

果然是2.6的問題, 換成2.51就正常了..
真是..@#$@##^$@..
花了我一整個晚上, 沒睡哩...唉...
還是多謝你了...


嗯, 不好意思,請問一下, 現在你們這群同好是不是多是台大新聞所的呀?

yoyolai 於 February 14, 2003 10:31 PM 所發表
[ 8 : 靜態鏈結 ]

喔.. 昏倒..
現在首頁可以了, 換成內文變亂碼...>:(
$@$!!!@%

yoyolai 於 February 14, 2003 10:37 PM 所發表
[ 9 : 靜態鏈結 ]

呃,不是,我既不是讀台大也不是新聞所.....

Jedi 於 February 14, 2003 11:16 PM 所發表
[ 10 : 靜態鏈結 ]

yoyolai: 這兒的人很多是藝立協的人及其附屬, ....台大新聞所目前寫blog的只有兩個人

hanteng 於 February 15, 2003 11:11 AM 所發表
[ 11 : 靜態鏈結 ]

「藝立協的人及其附屬」...這聽起來怎麼怪怪的? :p
好啦,這裡不討論政治問題。我要說的是, digdog 身為 Mac z6i 果然做出來的圖檔字型更好看啊!!!

Jedi 於 February 15, 2003 02:01 PM 所發表
[ 12 : 靜態鏈結 ]

我裝了一套MT2.62,當發佈中文資訊自動轉換成編輯模式後就是亂碼,但文章是正常的。不知道什麼地方出了問題?

ryan 於 February 25, 2003 09:40 AM 所發表
[ 13 : 靜態鏈結 ]

Ryan,
我想你的問題跟我昨天問躲同學的是一樣的
請去看mt.cfg
把NoHTMLEntities前面的#取消
然後後面的值改成1
這樣應該就可以了

Alice 於 February 25, 2003 10:54 AM 所發表
[ 14 : 靜態鏈結 ]

整了大半天,看到Alice的才弄好了。
多谢了

dais 於 June 7, 2003 01:11 AM 所發表
給我迴響吧!